Alles über 3.1.8 - 3.2 und seine Extensions

Ich bin zu doof dazu?!?!?

#1  Beitragvon Sijanca » Mi 15. Feb 2017, 13:50

Ich hab in meiner Familienversammlung immer noch Version 3.1.7pl1

Heute bin ich wieder auf phpbb.de gegangen, hab mir das Update .zip für diese Version auf 3.1.10 geholt und wollte das einspielen. Forum deaktiviert, Backup gemacht, Styles und Erweiterungen deaktiviert und dann...

Ordner docs, vendor und install per ftp hochgeladen. Installer gestartet. Tja und irgendwann lande ich in einer Sackgasse. Wenn der Installer über FTP hochladen will, gebe ich meine Daten ein, aber er kriegt keine Verbindung. Also geh will ich gucken, was er mir bei einem "Manuellen" Weg anweist. Ich bekomme eine Liste von diversen Dateien, die gelöscht sind oder sonst wie nicht passen. Und was soll ich damit machen? Irgendwann geht es dann einfach nicht weiter, im schlimmsten Fall endet es in einem weißen Bildschirm mit kryptischen Buchstabensalat, der keine Fehlermeldung ist und nichts.
Also hab ich alles wieder zurückgesetzt und lebe nun immer noch mit 3.1.7pl1.

Ich hab keine Lust mehr! :rote_karte:
This signature is under construction
Sijanca
Benutzeravatar
Specht
Specht

Re: Ich bin zu doof dazu?!?!?

#2  Beitragvon waldkatze » Mi 15. Feb 2017, 15:51

Welches FTP-Programm verwendest du ?
Empfohlen wird: https://filezilla-project.org/
Beachte das du die Dateien im binären Modus hochladen musst !!!
Motorrad fahren ist die schönste Sache die man angezogen machen kann ...

Die Oberlausitz ist ein widerrechtlich von Sachsen besetzt gehaltenes Territorium !
waldkatze
Benutzeravatar
Geier
Geier

Re: Ich bin zu doof dazu?!?!?

#3  Beitragvon Rick50 » Mi 15. Feb 2017, 19:43

Das pl1 ist doch eine spezielle Zwischenversion. Kann man das so einfach updaten? Bin mir da nicht sicher jetzt.
Wenn Du denkst Du denkst, dann Denkst Du nur Du denkst. Denkst Du?
Bild
Rick50
Benutzeravatar
Tippgemeinschaft
Tippgemeinschaft

Re: Ich bin zu doof dazu?!?!?

#4  Beitragvon waldkatze » Mi 15. Feb 2017, 21:52

Die Zwischenversionen spielen dabei keine Rolle.
Wichtig: php-Version bei deinem Hoster auf php 5.6 einstellen !!!... Nicht php 7 verwenden (das geht erst mit phpBB 3.2.x)

Update nach dieser Anleitung: https://www.phpbb.de/kb/update31x
Dateien unbedingt nur im Binär-Modus hochladen (sonst Fehler)
Den Ordner /docs/ kannst du weglassen (enthält nur Info)

Ganz wichtig. Nicht das automatische Update verwenden ! Enthält einen Bug.
Lese in oben genannten Link: Manuelles Update
Motorrad fahren ist die schönste Sache die man angezogen machen kann ...

Die Oberlausitz ist ein widerrechtlich von Sachsen besetzt gehaltenes Territorium !
waldkatze
Benutzeravatar
Geier
Geier

Re: Ich bin zu doof dazu?!?!?

#5  Beitragvon Sijanca » Do 16. Feb 2017, 10:29

waldkatze hat geschrieben:Die Zwischenversionen spielen dabei keine Rolle.
Wichtig: php-Version bei deinem Hoster auf php 5.6 einstellen !!!... Nicht php 7 verwenden (das geht erst mit phpBB 3.2.x)

Update nach dieser Anleitung: https://www.phpbb.de/kb/update31x
Dateien unbedingt nur im Binär-Modus hochladen (sonst Fehler)
Den Ordner /docs/ kannst du weglassen (enthält nur Info)

Ganz wichtig. Nicht das automatische Update verwenden ! Enthält einen Bug.
Lese in oben genannten Link: Manuelles Update


Danke für den Link. Aber schlauer bin ich damit auch nicht. Was heißt "Binär-Modus"?

Also php5.6 hab ich eingestellt. Daran liegt es nicht.

Bisher hab ich tatsächlich den automatischen Updater benutzt.

Na gut, dann fängt der Groschen doch wieder an zu rollen... Wenn ich nicht dieses zip von Version x auf Version y benutzten soll, was mache ich dann? Nehm ich dann stattdessen das zip mit der Vollversion? Aber das kann doch gar nicht funktionieren. Im Link steht, dass sich die aktuellen Version immer auf die vorherige Version beziehen und ich hab doch mehrere Versionen dazwischen. Muss ich dann etwa Schritt für Schritt alle Versionen nacheinander installieren?

Oh man, ich und selber hosten...

Und wie ist das dann mit meinem Haufen an Styles und Extensions. Muss ich die dann auch jedes mal einzeln runterladen und neu installieren? Himmel, ist das kompliziert!
This signature is under construction
Sijanca
Benutzeravatar
Specht
Specht
folgende User möchten sich bei Sijanca bedanken:
Protokoll Anzeigen


Re: Ich bin zu doof dazu?!?!?

#6  Beitragvon waldkatze » Do 16. Feb 2017, 12:06

Zum Binär-Modus hier lesen: https://www.phpbb.de/kb/binaer_ascii

1.Datensicherung aller Dateien und der Datenbank nicht vergessen !

2. Board deaktivieren, alle Extensionen deaktivieren (aber nicht löschen !) und alle Dateien vom Server löschen außer:

config.php
.htaccess (wenn modifiziert)
ext/
styles/
store/
files/
images/


3. Für das Update auf phpBB 3.1.10 verwendest du die Vollversion. Download: https://www.phpbb.de/downloads/pakete.php
Dateien entpacken und alles im Binärmodus auf den Server laden.
Beachte das folgende Dateien nicht überschrieben werden dürfen:

config.php
.htaccess (sofern modifiziert)
ext/ (optional: wenn Erweiterungen/Extensions installiert sind)
styles/ (optional: wenn zusätzlich zu prosilver andere Styles installiert sind)
store/ (optional; enthält Backup-Dateien angelegt über den phpBB-Admin-Bereich)
files/ (optional; enthält hochgeladene Dateien)
images/ (optional; sonst gehen Avatare, Rangbilder, Smilies und Beitragssymbole verloren, die nachträglich ergänzt wurden)


4. Danach ruftst du das eigentliche Update auf: http://www.deine_domain/forumverzeichni ... update.php

Du kannst damit direkt auf Version 3.1.10 gehen.
Motorrad fahren ist die schönste Sache die man angezogen machen kann ...

Die Oberlausitz ist ein widerrechtlich von Sachsen besetzt gehaltenes Territorium !
waldkatze
Benutzeravatar
Geier
Geier
folgende User möchten sich bei waldkatze bedanken:
Protokoll Anzeigen


Re: Ich bin zu doof dazu?!?!?

#7  Beitragvon Rick50 » Do 16. Feb 2017, 23:14

So könnte sie doch gleich auf 3.2.0 gehen, oder?
Wenn Du denkst Du denkst, dann Denkst Du nur Du denkst. Denkst Du?
Bild
Rick50
Benutzeravatar
Tippgemeinschaft
Tippgemeinschaft

Re: Ich bin zu doof dazu?!?!?

#8  Beitragvon Rick50 » Fr 17. Feb 2017, 16:42

Bin mir jetzt nicht sicher, aber gibt es im 3.2.0 nicht Änderungen in den Styles, weswegen man die prosilver überschreiben muss? Oder habe ich da was falsch gelesen?
Wenn Du denkst Du denkst, dann Denkst Du nur Du denkst. Denkst Du?
Bild
Rick50
Benutzeravatar
Tippgemeinschaft
Tippgemeinschaft

Re: Ich bin zu doof dazu?!?!?

#9  Beitragvon waldkatze » Fr 17. Feb 2017, 21:06

Rick50 hat geschrieben:Bin mir jetzt nicht sicher, aber gibt es im 3.2.0 nicht Änderungen in den Styles, weswegen man die prosilver überschreiben muss? Oder habe ich da was falsch gelesen?


Ja, da hast du völlig Recht. Wenn du auf phpBB 3.2.0 updaten willst, müssen die neuen Dateien vom Style "prosilver" eingefügt werden.
Der Style enthält Änderungen gegenüber der Version 3.1.10
Motorrad fahren ist die schönste Sache die man angezogen machen kann ...

Die Oberlausitz ist ein widerrechtlich von Sachsen besetzt gehaltenes Territorium !
waldkatze
Benutzeravatar
Geier
Geier
folgende User möchten sich bei waldkatze bedanken:
Protokoll Anzeigen


Re: Ich bin zu doof dazu?!?!?

#10  Beitragvon Sijanca » So 19. Feb 2017, 19:49

Auf 3.2 will ich bei meinem laufenden Forum gar nicht gehen. Zumindest vorerst nicht.

Ich glaub ich bleib bei der alten Version. Ich bin total unsicher. Will doch mein mühsam aufgebautes Forum nicht kaputt machen.
This signature is under construction
Sijanca
Benutzeravatar
Specht
Specht

Re: Ich bin zu doof dazu?!?!?

#11  Beitragvon Rick50 » So 19. Feb 2017, 20:25

Da machst Du nichts kaputt. Sicherungen darfst halt nicht vergessen. An diese Updates/ Upgrades muss man sich als Selbsthoster gewöhnen. Zudem es immer einfacher wird, je öfter man es macht.
Ich war überascht wie viele Extensions bereits wieder funktionieren.
Wenn Du denkst Du denkst, dann Denkst Du nur Du denkst. Denkst Du?
Bild
Rick50
Benutzeravatar
Tippgemeinschaft
Tippgemeinschaft